Quantcast Melco XT PCB ASSY, CONTROL BOARD break machine 2006


discussion boards mailing list tips / tricks / forms designs suppliers find a shop marketplace

  main menu

  hoops / hooping
  stock designs

Tips & Tricks
  main menu

Mailing List
  sign up now
my account

Amaya Shops
  locate a shop

  shop for supplies

  official Melco site
  online resources


Help Support This Site:



Results 1 to 4 of 4
  1. #1
    Join Date
    May 2015
    Post Thanks / Like

    Melco XT PCB ASSY, CONTROL BOARD break machine 2006


    We have 6 machines and know the second controlboard break somebody know witch component is break ??????

    Are melco machines from 2006 xt 2 machines start 100% same machine stop and only red laser dot in the beginning need wait 5 minutes later 10 minutes later 30 minutes and know half day and then will work again.

    If know witch component possible we can repair, think is all the same problem with this boards from this year maybe more people have had this problem.

    We like to hear from you,

    Best regards,


    The Netherlands.
    Last edited by logo-borduren; 11-19-2019 at 06:12 AM.

  2. #2
    Join Date
    Oct 2010
    Etna, CA
    Post Thanks / Like

    my search results

    I would tell you to do a search on "PCB board," but because English is not your first language that seemed cruel--here is what I have found; it is a beginning so that you can tell us what you have tried.

    1)First, have you looked at your PCB? Are all the lights on and brightly lit? Are all the wires tightly connected and free of corrosion? Have you checked all the cords and cables for this machine. I would tell you to check that the machine isn't "sleeping" or that you emergency stop button isn't engaged, but since the machine does come on later, these shouldn't be the problem.

    2)There is one possibility.......the controller/keypad should have the green LED flashing. If the green led is not flashing on the keypad you may need to check the Ethernet cable on the back of the keypad. If that is connected and it's still not flashing then you have an internal problem with the keypad or an internal problem on the machine. In either case you need a tech visit.

    The flashing LED indicated that the Ethernet connection is not established. When that connection is good the LED will go solid and the OS screen will load the last job ran on the machine.

    so if both of you are lucky. One will have a bad or wrong Ethernet cable and the other will not have the keypad connected.

    you need to think back did you have it connected to a hub or was it directly to the PC. directly to the PC requires a crossover cable.


    3)If this machine has its own battery back-up, read this:
    There appears to be a clue as to what the issue may be related to in your statement.....Quote..( and the power was off longer than the power supply would keep it going)..... Power supply? You mean battery back-up? If this is so, is the battery back-up possibly malfunctioning? Is the battery in this system holding a charge, able to recharge, etc, etc..

    I would remove the battery backup system as a process of elimination and see if the machine will come on line and work properly with a direct source of power from the wall plug for a check...

    Rod Springer

    4)A common problem with Big Reds and, to lesser degree, XT's is a communication failure between the keypad PCB and the mother board. This can be caused by the stop button being held down longer than necessary to stop the machine but not long enough to put it to sleep - the machine enters a sort of limbo and will not respond to start or sleep commands.

    The solution is simple. Before doing anything else, hold down the stop button long enough to either put the machine to sleep or until you hear a click in the machine (10 seconds or so). Then press the start button. If it doesn't start immediately, hold the start button for a few seconds and it should start.

    We think this was caused by a newbie freaking out and mashing the daylights out of the start button which she was trying to use to stop the machine.

    Something else that can cause interference is a loose emergency stop button which can be tightened by unhooking the keypad from the machine, laying it face down, opening the back, and tightening the screws holding the E stop button in place. I haven't tried this yet.

    Mama Kass

  3. #3
    Join Date
    May 2015
    Post Thanks / Like
    Thanks, I also think it is an problem with the capacitor this you mean with the battery all is running again, have 1 old board order new capacitor like see if this start working again, is possible out the capacitor and running the machine this is what you mean ???

  4. #4
    Join Date
    Oct 2010
    Etna, CA
    Post Thanks / Like
    I don't understand what you are asking. The back-up capacitor is inside the Amaya and allows the machine to return to the state it was in when it was powered down. In other words, if you have a power failure in the middle of sewing a design, the design will continue sewing where it stopped when the power returns. The capacitor can be drained. Here is a link from Melco about this topic (see the bottom of the page - Power Up Behavior):

    The battery back-up (referred to in #3 above) is something you purchase and plug the Amaya into; it continues to provide power to the machine when the primary source of power is unavailable. If you have one of these, it usually gives you enough time to finish sewing out your design; then you turn the machine off yourself.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  a Levelbest Network Site - 2013

This site is not owned by or affiliated with Melco or any companies or subsidiaries.